Monday, August 08, 2005

ลง Fink บน Panther ไม่ได้ !

อุตส่าห์หาเครื่อง Mac เก่าๆที่ใช้ Panther ออกมาจากลิ้นชัก ว่าจะเอามาคอมไพล์ Firefox สำหรับ Mac สักหน่อย หลังจากปล่อยให้ล้าหลัง Windows มานาน

ก่อนอื่นก็ไป D/L Fink มาลง เพื่อเตรียมเครื่องให้พร้อมสำหรับคอมไพล์ ปรากฏว่าพอเรียก "Fink 0.8.0 Installer" ปุ้บ มันบอกว่า "ติดตั้ง Fink บนเครื่องนี้ไม่ได้ ต้องการ Mac OS X 10.4 (Tiger) ขึ้นไป"

โคตรเกลียดแมคตรงนี้เลย ออก OSX เวอร์ชั่นใหม่หน่อยเดียว อะไรอะไรก็วิ่งตามรุ่นใหม่หมด รุ่นก่อนหน้าใช้ไม่ได้ หรือถูกแช่แข็งไม่พัฒนาต่อ วันก่อนจะลง Java 1.4 ก็ต้องมี Panther OSX 10.3 เป็นอย่างต่ำ ลงบนเครื่องที่ใช้ OS X 10.2 ไม่ได้ ตอนนี้ถ้าจะเล่น Java 1.5 ก็ต้องใช้ OS X 10.4 Tiger ขึ้นไป Panther ใช้ไม่ได้

แล้วไม่ยอมออก Java 1.4/1.5 บน OS X ก่อนหน้ารุ่นที่กำหนดเลย หาเรื่องให้ลูกค้า Upgrade ตามตลอด อาจจะมีผู้พัฒนาน้อย ต้องรวมพลังเฉพาะกับรุ่นล่าสุด ไม่มีเวลาไป Support รุ่นเก่าๆ แล้วก็ไม่ใช่นานๆครั้งนะ แป้บๆก็วิ่ง OSX 10.2 -> 10.3 -> 10.4 ไม่ฟรี ต้องเสียตังค์อีกต่างหาก

ในทางตรงข้าม โปรแกรมของ Windows ที่ติดกับ OS ขนาดนี้ไม่ค่อยมี ป่านนี้แล้วหลายคนยังใช้ Windows 2000 ได้สบายๆ

2 comments:

bact' said...

เห็นด้วยครับ

ตอนนี้ก็ใช้ Java 5 ไม่ได้ เพราะเครื่องยังเป็น 10.3 อยู่ :(

vee said...

กะจะมา post เหมือนท่าน bact' เลย :-P
อยากใช้ Java 5 มากอะ แต่ไม่อยากซื้อ Tiger ( ตอนนี้ )

ป.ล. Darwin ports rulez :-P